Windows 7: “nicht identifiziertes Netzwerk”

Ich hatte mich ja lange dagegen gewehrt, von Windows XP auf eine neuere Version umzusteigen, insbesondere nach der grauenhaften Vorstellung von Vista stand mir nicht der Sinn nach einem neuen Betriebssystem, das nur mäßig sicherer, dafür aber massiv nutzerunfreundlicher ist.

Mit dem im Artikel weiter unten bereits erwähnten neuen Notebook blieb mir dann aber kaum eine andere Wahl und die erste freudige Überraschung stand kurz nach dem allerersten Start an: beim Einspielen der 53 notwendigen Updates hängte sich der Rechner beim Update 52 auf, danach war das System nur durch Starten im angesicherten Modus und Zurücksetzen auf einen älteren Wiederherstellungspunkt wieder zum Laufen zu bewegen – Totalabschuss. Die im Netz hierzu gefundene Lösung war übrigens die Updates im betrieb manuell einzuspielen, statt automatisch beim Herunterfahren des Geräts… An der Stelle hatte ich die Faxen schon ziemlich dicke.

Aber Microsoft hatte noch einen weiteren schönen Spaß für mich bereit gehalten. Nachdem ich das Notebook im Büro ab und im Wohnzimmer wieder aufgebaut hatte (exakt für sowas ist es ja da), meldete mir die WLAN-Verbindung “nicht identifizierbares Netzwerk” und wollte mich deswegen aufgrund von Sicherheitsbedenken nicht mehr ins Internet lassen. Na toll…

Die eingeleitete Suche auf dem glücklicherweise vorhandenen anderen Rechner im Raum brachte zum Suchbegriff “Windows 7 nicht identifiziertes Netzwerk” 53000 Treffer und diverse Hinweise darauf, dass dieses Problem seit Monaten bekannt ist, Microsoft allerdings nichts daran ändert. Dummerweise fanden sich Hinweise zur der Problematik hauptsächlich in Foren, auf denen sich immer wieder gern irgendwelche selbsternannten Schlaumeier und Wichtigtuer herum treiben und völlig untaugliche Lösungsvorschläge machen; gern genommen ist “Windows neu aufsetzen”.  Das kann bei einer nagelneuen Win7-Installation natürlich nicht die Lösung sein.

Andere schlugen vor, vom Empfang einer IP-Adresse via DHCP auf eine feste, manuell vergebene unzustellen, das hatte ich allerdings bereits erfolglos versucht. Dann gab es noch diverse Voodoo-Lösungen mit resetteten Routern und Einschaltreihenfolgen, die zwar selbstverständlich erfolgreich sein können – aber zufriedenstellend war das alles nicht.

Auch das Entfernen von Netzwerkadaptern und WLAN-Netzwerken in der Systemsteuerung brachte keinen Erfolg.

Lösung und Hintergrund:

Manchmal verzögert sich die Zuteilung einer DHCP-Adresse an Windows, das liegt in aller Regel an Boot-Verzögerungen am System und nicht am DHCP-Server. Kommt die Adresse nicht rechtzeitig, trägt Windows sich selbst eine Art Hilfs-IP-Adresse ein, die mit 169 beginnt und als unsicheres Netzwerk behandelt wird.

Dummerweise wird das dann auch gleich in der Registry eingetragen, zusammen mit der MAC-Adresse des Routers und Windows 7 bedient sich ab sofort fälschlicherweise dieses Eintrags.

Die Lösung ist den entsprechenden Registry-Eintrag zu löschen (und sicherheitshalber eine feste IP zu vergeben, die außerhalb des IP-Adressen-Bereichs des DHCP-Servers liegt). Wie immer bei Änderungen in der Registry sei darauf hingewiesen, dass man wissen sollte was man tut, da man sich durch untaugliche Änderungen in der Registrierungsdatenbank das System heftigst und unwiederbringlich zerschießen kann.

Im Pfad

HKCU\Software\Microsoft\Windows\CurrentVersion\InternetSettings\

löscht man den Eintrag (Ordner)

WPAD

in dem die falschen Einstellungen gespeichert sind.

Danach ein Neustart und sich wieder mit dem gewünschten Netzwerk verbinden, hierzu muss aller Wahrscheinlichkeit nach der WPA-Key neu eingegeben werden. Nach dem, was ich an verschiedenen Stellen im Web so fand, sollte das Problem danach angeblich dauerhaft beseitigt sein, was ich mindestens dann bezweifle, wenn man sich an neuen, bisher unbekannten WLAN-Netzen anmeldet, da kann das meiner Ansicht nach immer wieder vorkommen.

Ich habe dann noch den WiFi-Sniffer angeworfen und der brachte zutage, was ich mir schon fast gedacht hatte: in letzter Zeit hatten sich wohl etliche Nachbarn WLAN-Router zugelegt und vorsichtshalber mal nicht nachgesehen, welche Kanäle bereits belegt sind (ich gebe zu, dass das der unbedarfte Nutzer auch nicht unbedingt wissen kann). Deswegen tummelte sich auf dem von mir damals belegten Kanal (der war frei und die jeweiligen Nachbarkanäle ebenfalls) jetzt gleich mehrere fröhlich funkende Geräte. Ich kann hier nur vermuten, dass die Windows ein wenig aus dem Tritt gebracht haben. Jetzt sendet mein Router wieder auf einem freien Kanal mit zu jeder Seite einem weiteren Kanal Abstand. Ich kann nur hoffen, dass sich die zukünftig noch hinzukommende Anzahl neuer WLAN-Funker in Grenzen hält…

Da das Problem mit dem “nicht identifizierten Netzwerk” allerdings nach meinen Recherchen auch mit kabelgebundenen Verbindungen auftritt, war das nur eine Zusatzmaßnahme. Das grundsätzliche Problem liegt bei Windows 7 bzw. dessen DHCP-Handling und dem voreiligen Eintragen in die Registry. Wollen wir hoffen, dass Microsoft das mit dem angekündigten ersten Servicepack behebt…

Ihnen hat dieser Artikel gefallen oder geholfen? Prima! Dann denken Sie doch an mich, wenn Sie eine Webseite benötigen!

Dieser Eintrag wurde veröffentlicht in Windows 7 und getagged , , , , , , . Bookmarken: Permanent-Link. Kommentieren oder ein Trackback hinterlassen: Trackback-URL.

8 Kommentare

  1. Klaus Bertram
    Erstellt am 1. Januar 2012 um 19:15 | Permanent-Link

    Hallo Stefan,

    vielen Dank für diese hilfreiche Beschreibung/Einschätzung! Auch ich muss mich nunmehr an Windows 7 gewöhnen, mit all den ganzen Spielereien und vermeintlich erleichternden Neuerungen.

    Meiner persönlichen Meinung nach ist Windows 7 grenzenlos überladen, benutzerunfreundlich und nervtötend verspielt. Ich nutze das System rein zum Arbeiten, diese ganzen Spielereien und Effekte sind für mich bestenfalls nervraubend. Vergleichbar zu der Technik in heutigen Autos, muss man aber mit dem (für mich) unnützen Schnick Schnack leben lernen.

    Technischer Zusatz:

    Die Verbindungsproblematik ergab sich bei mir nicht bei einem WLan Netzwerk (wie in Deinem Beitrag beschriebe), bei der drahtlosen Verbindung klappte alles auf Anhieb. Das Problem tauchte erst bei Einrichten einer kabelgebundenen Verbindung auf, konnte aber durch das Löschen des sinnfreien Registry Eintrags behoben werden. Demnach kann einem dieses Problem bei jedweder Netzwerkverbindung begegnen, diese Frage blieb in Deinem Beitrag noch offen.

    Vielen Dank für Deinen Beitrag & viel Glück mit Windows 7 (ff.)!

  2. Julian
    Erstellt am 25. April 2012 um 17:33 | Permanent-Link

    Habe die Datei gelöscht und den Computer neu gestartet. Aber es ging immernoch nicht, die Datei ist weiterhin weg, hat jemand eine Lösung?

  3. Stefan Holzhauer
    Erstellt am 25. April 2012 um 21:39 | Permanent-Link

    Welche Datei? Den Registry-Schlüssel?

    Der Link zum anderen Windows-7-Artikel zu diesem Thema steht unter dem Artikel (ändern der MAC-Adresse). Den ebenfalls ausprobieren.

  4. Julian
    Erstellt am 26. April 2012 um 08:53 | Permanent-Link

    Danke für deine Antwort geht auf einmal wieder

  5. Marcel
    Erstellt am 24. September 2012 um 17:39 | Permanent-Link

    Hallo,

    bei mir funktioniert die Verbindung nach dem Durchführen der Schritte noch immer nicht.
    Ich bin echt der totalen Verzweiflung nahe!
    Router (FritzBox 7390)

    Was kann ich noch machen?
    Danke

  6. Harry
    Erstellt am 23. Februar 2013 um 13:31 | Permanent-Link

    Hallo,

    ich hatte mal ein ähnliches Problem. Neuer Router aber keine Internetverbing und auch das Netzwerk ließ sich nicht identifizieren. Meine Lösung war das herunterladen des aktuellen Treibers für die WLAN-Karte direkt vom Hersteller bzw. der Website des Herstellers. Kurzer Neustart und alles lief einwandfrei.

    Liebe Grüße
    Euer Harry

  7. Stefan Holzhauer
    Erstellt am 23. Februar 2013 um 13:51 | Permanent-Link

    Hatte ich versucht, war in meinem Fall nicht erfolgreich gewesen.

  8. Lynè
    Erstellt am 3. Mai 2013 um 10:31 | Permanent-Link

    Hallo Stefan,
    vielen Dank für deine Lösung, ich habe mich schon länger mit diesem Problem herumgeärgert, dass Microsoft das nicht endlich fixed ist mir ein Rätsel.
    In Kombination mit einer festen IP funktioniert nun alles wunderbar!

    Danke, danke danke!

4 Trackbacks

  1. [...] das Problem “nicht identifiziertes Netzwerk” hatte ich ja bereits berichtet und eine Lösung gefunden. Dachte [...]

  2. [...] AW: Nicht identifiziertes Netzwerk Dann hilft nur noch das: Windows 7: “nicht identifiziertes Netzwerk” [...]

  3. [...] [...]

  4. [...] kam ich der Lösung über zwei Blogartikel: Windows 7: “nicht identifiziertes Netzwerk” in Version 1 und Version 2. Die Erkenntnis dank Stefan Holzhauer: Wenn sich sich die Zuteilung einer [...]

Ihr Kommentar

Ihre E-Mail wird niemals veröffentlicht oder verteilt. Benötigte Felder sind mit * markiert

*
*

Du kannst diese HTML Tags und Attribute verwenden: <a href="" title=""> <abbr title=""> <acronym title=""> <b> <blockquote cite=""> <cite> <code> <del datetime=""> <em> <i> <q cite=""> <strike> <strong>


sechs × = 30